2
0
mirror of https://github.com/xcat2/xcat-dep.git synced 2024-11-21 17:11:45 +00:00
xcat-dep/syslinux/debian/rules
hamzy bf08ce086d This is the first draft of building packages under Debian
Former-commit-id: 342cdeb67cc99dc5c0da1095d07cf5f239b58c4c
2011-05-03 20:29:30 +00:00

104 lines
2.2 KiB
Makefile

#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# This file is public domain software, originally written by Joey Hess.
#
# This version is for packages that are architecture dependent.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
#export buildroot=`pwd`/debian/`dh_listpackages`
export buildroot=`pwd`/debian/tmp
export bindir=$(buildroot)/usr/bin
export sbindir=$(buildroot)/usr/sbin
export libdir=$(buildroot)/usr/lib/syslinux
export datadir=$(buildroot)/usr/lib
export mandir=$(buildroot)/usr/share/man
export includedir=$(buildroot)/usr/include
build: build-stamp
build-stamp:
dh_testdir
# Add here commands to compile the package.
$(MAKE) -C com32
$(MAKE) installer
$(MAKE) -C sample tidy
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
# Add here commands to clean up after the build process.
$(MAKE) clean
#$(MAKE) distclean
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
# Add here commands to install the package into debian/<packagename>
#INSTALLROOT=$(buildroot)
$(MAKE) install-all \
BINDIR=$(bindir) SBINDIR=$(sbindir) \
LIBDIR=$(libdir) DATADIR=$(datadir) \
MANDIR=$(mandir) INCDIR=$(includedir) \
TFTPBOOT=$(buildroot)/opt/xcat/share/xcat/netboot/syslinux EXTLINUXDIR=$(buildroot)/boot/extlinux
$(MAKE) -C sample tidy
dh_movefiles
#$ (MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs
dh_installexamples
# dh_install
# dh_installmenu
# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installcatalogs
# dh_installpam
# dh_installmime
# dh_installinit
# dh_installcron
# dh_installinfo
# dh_installwm
# dh_installudev
# dh_lintian
# dh_bugfiles
# dh_undocumented
dh_installman
dh_link
dh_strip
dh_compress
dh_fixperms
# dh_perl
# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install