mirror of
https://github.com/xcat2/xcat-dep.git
synced 2024-11-21 09:01:46 +00:00
153 lines
4.7 KiB
RPMSpec
153 lines
4.7 KiB
RPMSpec
#
|
|
# - IO::Tty -
|
|
# This spec file was automatically generated by cpan2rpm [ver: 2.027]
|
|
# The following arguments were used:
|
|
# IO-Tty-1.07.tar.gz --no-upgrade-chk
|
|
# For more information on cpan2rpm please visit: http://perl.arix.com/
|
|
#
|
|
|
|
%define pkgname IO-Tty
|
|
%define filelist %{pkgname}-%{version}-filelist
|
|
%define NVR %{pkgname}-%{version}-%{release}
|
|
%define maketest 1
|
|
|
|
name: perl-IO-Tty
|
|
summary: IO-Tty - Pseudo ttys and constants
|
|
version: 1.07
|
|
release: 1
|
|
vendor: Roland Giersig <RGiersig@cpan.org>
|
|
packager: Arix International <cpan2rpm@arix.com>
|
|
license: Artistic
|
|
group: Applications/CPAN
|
|
url: http://www.cpan.org
|
|
buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
|
|
prefix: %(echo %{_prefix})
|
|
source: IO-Tty-1.07.tar.gz
|
|
|
|
%description
|
|
"IO::Tty" is used internally by "IO::Pty" to create a pseudo-tty.
|
|
You wouldn't want to use it directly except to import constants, use
|
|
"IO::Pty". For a list of importable constants, see
|
|
IO::Tty::Constant.
|
|
|
|
Windows is now supported, but ONLY under the Cygwin
|
|
environment, see <http://sources.redhat.com/cygwin/>.
|
|
|
|
Please note that pty creation is very system-dependend. From my
|
|
experience, any modern POSIX system should be fine. Find below a list
|
|
of systems that "IO::Tty" should work on. A more detailed table
|
|
(which is slowly getting out-of-date) is available from the project
|
|
pages document manager at SourceForge
|
|
<http://sourceforge.net/projects/expectperl/>.
|
|
|
|
If you have problems on your system and your system is listed in the
|
|
"verified" list, you probably have some non-standard setup, e.g. you
|
|
compiled your Linux-kernel yourself and disabled ptys (bummer!).
|
|
Please ask your friendly sysadmin for help.
|
|
|
|
If your system is not listed, unpack the latest version of "IO::Tty",
|
|
do a 'perl Makefile.PL; make; make test; uname -a' and send me
|
|
(RGiersig@cpan.org) the results and I'll see what I can deduce from
|
|
that. There are chances that it will work right out-of-the-box...
|
|
|
|
If it's working on your system, please send me a short note with
|
|
details (version number, distribution, etc. 'uname -a' and 'perl -V'
|
|
is a good start; also, the output from "perl Makefile.PL" contains a
|
|
lot of interesting info, so please include that as well) so I can get
|
|
an overview. Thanks!
|
|
|
|
#
|
|
# This package was generated automatically with the cpan2rpm
|
|
# utility. To get this software or for more information
|
|
# please visit: http://perl.arix.com/
|
|
#
|
|
|
|
%prep
|
|
%setup -q -n %{pkgname}-%{version}
|
|
chmod -R u+w %{_builddir}/%{pkgname}-%{version}
|
|
|
|
%build
|
|
grep -rsl '^#!.*perl' . |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
|
|
CFLAGS="$RPM_OPT_FLAGS"
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
|
|
%{__make}
|
|
%if %maketest
|
|
%{__make} test
|
|
%endif
|
|
|
|
%install
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
|
|
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
|
|
|
|
cmd=/usr/share/spec-helper/compress_files
|
|
[ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
|
|
[ -x $cmd ] && $cmd
|
|
|
|
# SuSE Linux
|
|
if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
|
|
then
|
|
%{__mkdir_p} %{buildroot}/var/adm/perl-modules
|
|
%{__cat} `find %{buildroot} -name "perllocal.pod"` \
|
|
| %{__sed} -e s+%{buildroot}++g \
|
|
> %{buildroot}/var/adm/perl-modules/%{name}
|
|
fi
|
|
|
|
# remove special files
|
|
find %{buildroot} -name "perllocal.pod" \
|
|
-o -name ".packlist" \
|
|
-o -name "*.bs" \
|
|
|xargs -i rm -f {}
|
|
|
|
# no empty directories
|
|
find %{buildroot}%{_prefix} \
|
|
-type d -depth \
|
|
-exec rmdir {} \; 2>/dev/null
|
|
|
|
%{__perl} -MFile::Find -le '
|
|
find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
|
|
print "%doc README";
|
|
for my $x (sort @dirs, @files) {
|
|
push @ret, $x unless indirs($x);
|
|
}
|
|
print join "\n", sort @ret;
|
|
|
|
sub wanted {
|
|
return if /auto$/;
|
|
|
|
local $_ = $File::Find::name;
|
|
my $f = $_; s|^\Q%{buildroot}\E||;
|
|
return unless length;
|
|
return $files[@files] = $_ if -f $f;
|
|
|
|
$d = $_;
|
|
/\Q$d\E/ && return for reverse sort @INC;
|
|
$d =~ /\Q$_\E/ && return
|
|
for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
|
|
|
|
$dirs[@dirs] = $_;
|
|
}
|
|
|
|
sub indirs {
|
|
my $x = shift;
|
|
$x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
|
|
}
|
|
' > %filelist
|
|
|
|
[ -z %filelist ] && {
|
|
echo "ERROR: empty %files listing"
|
|
exit -1
|
|
}
|
|
|
|
%clean
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
|
|
|
|
%files -f %filelist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Fri Apr 4 2008 root@node1.cluster
|
|
- Initial build.
|