2
0
mirror of https://github.com/xcat2/xcat-dep.git synced 2024-11-21 17:11:45 +00:00
xcat-dep/grub2-xcat/debian/rules
immarvin b77214f345 add debian packaging stuff
Former-commit-id: 5c33183ff85bfc046afb5a346b05ea95f19d5deb
2014-09-17 23:33:27 -07:00

73 lines
1.3 KiB
Makefile
Executable File

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
export DH_COMPAT=5
build:
pwd
tar -zxvf ./grub2-res.tar.gz
clean:
dh_testdir
dh_testroot
dh_clean -d
rm -rf ./powerpc-ieee1275
install:
pwd
dh_testdir
dh_testroot
dh_installdirs
dh_install -X".svn"
dh_link
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch:
pwd
export
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs
# dh_installexamples
dh_install -X".svn"
# dh_installmenu
# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_python
# dh_installinit
# dh_installcron
# dh_installinfo
dh_installman
# dh_link
# dh_strip
dh_compress
# dh_fixperms
dh_perl
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch clean
.PHONY: build clean binary-indep binary-arch binary install configure