mirror of
https://github.com/xcat2/xcat-dep.git
synced 2024-11-21 17:11:45 +00:00
65 lines
1.2 KiB
Makefile
Executable File
65 lines
1.2 KiB
Makefile
Executable File
#!/usr/bin/make -f
|
|
|
|
# Comment this to turn off verbose mode.
|
|
export DH_VERBOSE=1
|
|
|
|
# This has to be exported to make some magic below work.
|
|
export DH_OPTIONS
|
|
|
|
build: build-stamp
|
|
build-stamp:
|
|
dh_testdir
|
|
dh_quilt_patch
|
|
$(MAKE)
|
|
|
|
clean:
|
|
dh_testdir
|
|
dh_testroot
|
|
#$(MAKE) distclean
|
|
dh_clean
|
|
|
|
install: build
|
|
dh_testdir
|
|
dh_testroot
|
|
dh_clean -k
|
|
dh_installdirs
|
|
mkdir -p `pwd`/debian/`dh_listpackages`/tftpboot/xcat
|
|
cp elilo.efi `pwd`/debian/`dh_listpackages`/tftpboot/xcat/elilo-x64.efi
|
|
|
|
# Build architecture-independent files here.
|
|
binary-indep: install
|
|
dh_testdir -i
|
|
dh_testroot -i
|
|
dh_installdocs -i
|
|
dh_installchangelogs -i
|
|
dh_compress -i
|
|
dh_installdeb -i
|
|
dh_gencontrol -i
|
|
dh_md5sums -i
|
|
dh_builddeb -i
|
|
|
|
# Build architecture-dependent files here.
|
|
binary-arch: build install
|
|
dh_testdir -a
|
|
dh_testroot -a
|
|
dh_installinit -a
|
|
dh_installdocs -a
|
|
dh_installexamples -a
|
|
# dh_installmenu
|
|
# dh_installcron
|
|
dh_installdebconf -a
|
|
dh_installchangelogs -a
|
|
dh_link -a
|
|
dh_strip -a
|
|
dh_compress -a
|
|
dh_fixperms -a
|
|
dh_makeshlibs -a
|
|
dh_installdeb -a
|
|
dh_shlibdeps -a
|
|
dh_gencontrol -a
|
|
dh_md5sums -a
|
|
dh_builddeb -a
|
|
|
|
binary: binary-indep binary-arch
|
|
.PHONY: build clean binary-indep binary-arch binary install
|