xcat-core/xCAT-OpenStack/debian/rules
2013-11-07 00:06:16 -08:00

54 lines
1.5 KiB
Makefile
Executable File

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
build:
pwd
clean:
dh_testdir
dh_testroot
dh_clean -d
install:
pwd
dh_testdir
dh_testroot
dh_installdirs
`pwd`/db2man
dh_install -X".svn"
chmod 755 `pwd`/debian/xcat-openstack/opt/xcat/lib/perl/xCAT_schema
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/lib/perl/xCAT_schema/*
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/lib/perl/xCAT_plugin/*
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/lib/perl/xCAT/*
chmod 755 `pwd`/debian/xcat-openstack/opt/xcat/sbin/*
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/share/man/man5/*
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/share/doc/man5/*
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/share/man/man7/*
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/share/doc/man7/*
chmod 755 `pwd`/debian/xcat-openstack/install/postscripts/*
chmod 644 `pwd`/debian/xcat-openstack/opt/xcat/share/xcat/*
dh_link
binary-indep: build install
pwd
export
dh_installman
dh_compress
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
binary-arch:
pwd
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure