xcat-core/perl-xCAT/debian/rules
adalbas 01c40fe38c deb package files small changes
- added source/format
- change to perl-xCAt and xCAT debian


git-svn-id: https://svn.code.sf.net/p/xcat/code/xcat-core/trunk@10802 8638fb3e-16cb-4fca-ae20-7b5d299a9bcd
2011-10-17 18:13:45 +00:00

77 lines
1.8 KiB
Makefile
Executable File

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
export DH_COMPAT=5
build:
dh_testdir
./modifyUtils `cat ../Version`
./db2man
clean:
dh_testdir
dh_testroot
dh_clean -d
install:
dh_testdir
dh_testroot
dh_installdirs
dh_install
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs
# dh_installexamples
dh_install
chmod 644 `pwd`/debian/perl-xcat/opt/xcat/lib/perl/xCAT/*
chmod 755 `pwd`/debian/perl-xcat/opt/xcat/lib/perl/xCAT/data
chmod 644 `pwd`/debian/perl-xcat/opt/xcat/share/doc/packages/perl-xCAT/*
chmod 644 `pwd`/debian/perl-xcat/opt/xcat/README
chmod 644 `pwd`/debian/perl-xcat/opt/xcat/share/man/man5/*
chmod 644 `pwd`/debian/perl-xcat/opt/xcat/share/doc/man5/*
chmod 644 `pwd`/debian/perl-xcat/opt/xcat/share/man/man7/*
chmod 644 `pwd`/debian/perl-xcat/opt/xcat/share/doc/man7/*
# dh_installmenu
# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_python
# dh_installinit
# dh_installcron
# dh_installinfo
dh_installman
# dh_link
# dh_strip
# dh_compress
# dh_fixperms
dh_perl
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure